Troubleshooting internet disconnection and the UI failed to load error in AVG AntiVirus on Windows | AVG

Home Support

Troubleshooting internet disconnection and the UI failed to load error in AVG AntiVirus on Windows

If you are running AVG Internet Security or AVG AntiVirus FREE on Windows, you may experience the following issues:

  • Loss of internet connection
  • The UI fails to load and shows the error below

Follow the instructions in this article to resolve these issues:

Restart your PC

We recommend that you first restart your PC two times (waiting up to 5 minutes between restarts). During the restarts, AVG should update automatically to fix the issue.

If this does not resolve the problem, proceed with the additional steps below.

Further options

If restarting your PC two times did not resolve the issue, follow these steps:

  1. Fully uninstall AVG Internet Security or AVG AntiVirus FREE. For instructions, refer to the relevant article below:
  2. Restart your PC, then reinstall AVG Internet Security or AVG AntiVirus FREE. For instructions, refer to the relevant article below:
  3. Ensure that you have the latest application version by following the steps in the following article:

The AVG user interface now loads normally, and your internet connection should be restored.

  • AVG Internet Security 20.x
  • AVG AntiVirus FREE 20.x
  • Microsoft Windows 10 Home / Pro / Enterprise / Education - 32 / 64-bit
  • Microsoft Windows 8.1 / Pro / Enterprise - 32 / 64-bit
  • Microsoft Windows 8 / Pro / Enterprise - 32 / 64-bit
  • Microsoft Windows 7 Home Basic / Home Premium / Professional / Enterprise / Ultimate - 7 Service Pack 1 with Convenient Rollup Update, 32 / 64-bit

Was this article helpful?

Still looking for answers ?

Visit our AVG Support Community or contact us here: